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  Hands-on Activities for InTech Lab Workshop 
Photoshop for the Web 

Prepared by Jill Lenz 
Presented Spring 2009 

 
Goal:  Introduce users to general guidelines on optimizing digital images and producing .gifs and .jpgs for 
display on computer monitor screens, especially web pages, RamCT, PowerPoint presentations and 
multimedia CD/DVDs. 
 
Upon completion of this workshop, users should become familiar with: 
 

 Image acquisition tools available in the CVMBS InTech Lab 

 Digital imaging management tips 

 Photoshop preferences for the Web and PowerPoint images 

 How monitors display digital images 

 CMYK vs. RGB Color Mode 

 Rotating and cropping 

 “Save for Web & Devices” functions (available in Photoshop 6.0 and up) 

 Applying various quality compression levels in .jpgs to achieve smaller file sizes  

 Reducing colors in .gifs to achieve smaller file sizes   

 Transparency options for .gifs 

 Size Guidelines 

 Creating a Web Photo Gallery and File Info 

 

Units and Rulers Preferences for Screen Work 
 
Set “units of measure” options, as Web 
designers work in pixels on a screen, where 
folks in the print world work in inches and 
points on paper. 
 
1. Edit > Preferences > Units & Rulers 
2. Change units for both “Rulers” and “Type” 

to pixels. 
3. Click OK. 
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RGB Color Mode  
 

RGB or Additive Color Mode. If we are working on a computer, the colors we see on the screen are 
created with light using the additive color method. Additive color mixing begins with black and ends with 
white; as more color is added, the result is lighter and tends to white. 

Percentages of red, green, & blue light are used to generate color on a computer screen. 
 
When two primary colors overlap, the additive secondary colors (Cyan, 
Magenta, and Yellow), used for printing, are created. When all three 
primary colors are combined, you get white!  
 
Use the color wheel you create for reference when doing color corrections 
in retouching work: 
 
 Add more yellow to reduce bluish casts and vice versa 
 Add more magenta to reduce greenish casts and vice versa 
 Add more cyan to reduce reddish casts and vice versa 
 

In this exercise we create an image with three circles of color (Red, Blue and Green) to represent the 
additive primary colors, used for screen colors. This will also serve as a good review of the layer palette 
and the shape tool, and the color picker. 
 
1. File  New 

Complete the dialog box with the 
following values: 
 Width = 600 pixels 
 Height = 600 pixels 
 Resolution = 72 ppi for 

screen presentation. (Use a 
higher number for printing.) 

 Color Mode = RGB Color  
 Contents = Transparent 

2. Display the Layers Palette if 
necessary (Window > Show 
Layers) 

3. Rename the layer to “Red” 
(Double click on the layer name 
to rename) 

4. Select pure red for the Foreground Color Chip from the Color Picker numerically using the values R = 
255, G = 0, B = 0. 

5. Change the blending mode to Screen. 
6. Draw a circle with the Custom Shape Ellipse Tool.  

(For a perfect circle, hold down the SHIFT key before your initial click.) 
7. Duplicate the Red layer and rename it to Green. 

(Select the layer, right click and select Duplicate. You will be prompted to accept the default name or 
change it to Green.) 

8. Change the color to pure green.  
(Double click in the layers color chip and numerically select pure green using the values R = 0, G = 
255, B = 0.) 
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9. Using the Move tool, position the green layer so it overlaps the red layer. 
10. Duplicate the Green layer, rename it to Blue, recolor it pure blue and position it so it overlaps both the 

red and green layers. 
11. Save as circles.psd 
 
Save as .jpg 
 
File size for jpgs are controlled by the level of quality applied during the save function. We will save the 
same image at multiple quality settings and then inspect it at a high zoom level to compare. 
 
1. File > Open circles.psd 
2. File > Save for Web 

and Devises 
3. View the 2-up tab to 

see the original and a 
preview of how it will 
look after saving  

4. Verify the preview has 
the .jpg extension 
chosen 

5. From the Quality 
options directly below, 
use the drop arrow to 
access the different 
Quality levels. There is 
also a slider available 
for more precise 
control. Choose a 
modem speed from 
the top right arrow and 
Photoshop will list the 
approximate size and 
time of download in 
seconds per KB at the bottom of the image. This is important information for web designers.  
Guidelines for Image File Sizes 
 Web: High speed network (CVMBS) < 100 K 
 Web: Phone modems (off campus)  <    50 K 

6. Save separate copies of the circles file using three of the five Quality levels: 
 Low = 10% quality named circles_low.jpg 
 High = 60% quality named circles_high.jpg 
 Maximum = 100% named circles_max.jpg 

 
7. Open the three files you created. 
8. Use the Zoom Tool to enlarge each image to 200%. Inspect each image to see what artifacts have 

appeared at the different quality levels. Also, inspect the original PSD file at 200% for comparison. 
You can see that JPEG can introduce some imperfections when you’re using more compression. 
JPEG is not well suited to this type of line art. 
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9. Navigate to the directory with your saved images. Set View to Details and note the file sizes for the 
five files you created. We’ll see that for this kind of image, GIF is a better choice of file format. In 
the next exercise we will save this file as a GIF. 

10. Minimize the My Computer or Windows Explorer window showing the file names and sizes. 
11. When using JPEG, it’s best not to save and reopen and resave multiple times. This is because the 

artifacts that are introduced are cumulative. Save the circles_low.jpg image again using low quality 
and naming the new file circles_lowlow.jpg. Now look at the new file at 200% magnification. It looks 
pretty awful. This visually shows why files should be manipulated in PSD format preferably. 

12. Close all the circle files. 
 
In some cases your original is a .jpg, for example from a digital camera.  See if your camera can capture 
as a tif.  If not, capture JPGs at the largest setting, usually defined in HxW pixel dimensions. Keep your 
original jpgs as your untouched original archive copy. Then save a copy as a PSD for manipulating and 
preserving layers. 
 
Save as a .gif 
Same as previous 
exercise, except choose 
the .gif extension and 
instead of adjusting 
quality, reduce number of 
colors. 
 
1. Open circles.psd.  

Note that the file is in 
RGB mode with a 
transparent 
background in   
Photoshop 
represented by the 
checkerboard. 

2. Create a .gif from the 
original 
File  Save for Web & 
Devises  

3. View the 2-up tab 
4. Verify transparency is 

checked. 
5. Reduce the number of colors as much as possible to get a smaller file size. Note the number of colors 

needed to maintain exact quality as the original. 
6. Save the image as circles.gif. 

Note: the .gif extension will automatically appear.  Once saved, the .gif file will not automatically 
appear in PhotoShop until manually opened. 

7. Reopen Windows Explorer and view the details of the file sizes. This line art image achieves a 
smaller file size as a .gif vs. a jpg. 

 
JPGs  
Good for photos, radiographs, color blends, and 
gradients. Applies “lossy compression”. 

GIFs  
Good for transparent backgrounds and “flat 
color” line art with no shades of color. 
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Drawing on the left with no transparency, 
has a white box around it. Drawing on the 
right with transparency, appears to “float” 
on the background. Bonehead drawing by 
Cilla Rogers, PVM Class of 2000. 

Transparency Options  
 
1. File  Open boneheadicon.gif 
2. Image  Duplicate 
3. Verify Image   Mode to see if RGB or Indexed.  Since 

there are no original transparency features in this image, 
we need to duplicate the layer and add transparency.  The 
RGB mode allows layers so we must switch to RGB.  
Image  Mode  RGB 

4. Duplicate the background layer (drag to new layer icon on 
Layer Palette) 

5. Hide the background layer 
6. Use the Magic Eraser to erase the white around the edges 

to make the background transparent  
7. File  Save for Web  

Click on the 2-up tab.  Verify “transparency” is checked 
in the area to the right, OK.   

8. Save with a different name, boneheadicon2.gif 
9. To compare the two, open PowerPoint. Apply a colored 

background (Format > Background . . . )  
10. Insert  Picture  From File, boneheadicon.gif 

see white box around bonehead. 
11. Insert  Picture  From File, boneheadicon2.gif 

and see the transparency! 
 
 
 
 
Crop and Straighten Photos 
 

The Crop and Straighten Photos command, introduced in version CS, 
helps you make separate image files from multiple images in one single 
scan. For best results, you should keep an eighth of an inch between 
the images in your scan, and the background (typically the scanner 
bed) should be a uniform color. Images with clearly delineated outlines 
work best. I use a piece of black foam core for the background behind 
the photos and get better results with this function. 
 
1. File > Open dogs.psd, or the scanned file that contains the 

images you want to separate. 
2. Select the layer that contains the images. Alternately, draw a 

selection border around one or more images to generate just 
those images into separate files. 

3. Choose File > Automate > Crop and Straighten Photos. The 
scanned images are processed, and then each image opens in 
its own window ready for saving. 

Only GIFs support transparency. 
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4. If the Crop and Straighten Photos command incorrectly splits one of your images, make a selection 
border around the image and some background, and then hold down Alt (Windows) or Option (Mac 
OS) when you choose the command. The modifier key indicates that there is just one image to 
separate from the background. 

5. Rotate new separate images if needed. (Image > Rotate Canvass.) 
6. Save individual images with new names. 
 
If the Crop and Straighten Photos command isn't processing difficult images, use the Crop tool and Image 
Rotate menu commands to crop out individual images. At least you only had to scan once. 

 
 

 
 

 
Size Guidelines 
Size consists of: 

 HxW * 
 Disk memory size in KB or MB 
 Resolution in dpi or ppi 

 
*For on-screen images, the most important is HxW 
Since the image is displayed on a monitor screen 1:1, measured in pixels, you don’t need an image larger 
than the average screen size. Currently that size would be 1024x768. Past sizes have included 800x600 
and future sizes include 1280x1024 and wide screen dimensions. 
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Levels Adjustment Layers 
 
1. Open an image from the “levels” folder 

using Adobe Bridge.  
2. Image  Duplicate 
3. Make a copy of the background layer. 

Activate this new layer.  
 

4. Add a Levels adjustment layer using the 
“create new fill or adjustment layer” icon 
at the bottom of the layer palette and 
choosing “levels”. 

5. The Levels dialog box will appear 
showing a histogram of the image. 

 The histogram is a graphical 
representation of the pixels in the image, 
plotted from black (on the left) to white 
(on the right). There is no ideal histogram. 
Some may be biased to one side or the 
other. 

6. For beginners, select Auto, click OK 
7. Show and hide the adjustment layer to 

see the original vs. the changes with the 
new adjustment layer. 

8. Save the image as a .psd file with a new 
name. Close the original without saving. 
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File Info 
 
This allows entries for captions, 
keywords, categories, credits, and 
more. Some third-party image 
browsers can also search the 
captions and keyword entries.  If you 
plan to use an image database, start 
adding keyword entries to your 
images for easy searching. 
 
Choose File  File Info 
 
This is also where the Web Photo 
Gallery pulls information for 
displaying “titles” for Large Images 
and Thumbnails. “Titles” can include 
filename, Description, Credits, Title 
and Copyright. So if you want to 
display “titles” in your Web Photo 
Gallery, you will need to add the 
appropriate information in File Info 
for each image file. Please note: this 
is not available for all Photo Gallery site styles. If it is unavailable, the options will be “grayed out” as 
shown in the screen shot. 
 
Web Photo Gallery 
 
You use the Web Photo Gallery command to automatically generate a Web photo gallery from a set of 
images. A Web photo gallery is a Web site that features a home page with thumbnail images and gallery 
pages with full-size images. Each page contains links that allow visitors to navigate the site. For example, 
when a visitor clicks a thumbnail image on the home page, a gallery page with the associated full-size 
image loads. 
 
Photoshop provides a variety of styles for your gallery, which you can select using the Web Photo Gallery 
command. If you are an advanced user who has knowledge of HTML, you can also customize a style by 
editing a set of HTML template files or create a new style.  

 

1. Choose File > Automate > Web Photo Gallery. 

2. Under Files, click Source. Then select the folder containing the images that you want to appear in the 
gallery, and click OK. Select Include All Subdirectories to include images inside any subfolders of the 
selected folder.  For this exercise choose c:\userdata\yourname\ 

3. Click Destination. Then select the destination folder that you want to contain the images and HTML 
pages for the gallery, and click OK.  For this exercise choose “desktop” 

4. For Styles, choose a style for the gallery. A preview of the home page for the chosen style appears in 
the dialog box. 
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5. To set text options for the banner that appears on each page in the gallery, choose Banner from the 
Options pop-up menu. Then do the following: 

 Site Name The name of the gallery or it will default to “Adobe Web Photo Gallery” 

 Photographer The name of the person or organization receiving credit for the photos in the gallery.  
This is optional. 

 Contact Info The contact information for the gallery, such as a telephone number or a business 
address. This is optional. 

 Date The date appearing on each page 
of the gallery. By default, Photoshop 
uses the current date. 

 Font and Font Size (Available for some 
site styles) Options for the banner text. 
 

6. Large Images, the main image that appear 
on each gallery page, choose Large 
Images from the Options pop-up menu. 
Then do the following: 

 Add numeric links (Available for some 
site styles) Places a numeric sequence 
(starting at 1, ending with the total 
number of pages in the gallery) running 
horizontally at the top of each gallery 
page. Each number is a link to the 
respective page. 

 Resize Images Resizes the source 
images for placement on the gallery 
pages. Choose a size from the pop-up 
menu or enter a size in pixels. For 
Constrain, choose which dimensions of 
the image you want to constrain during resizing. For JPEG Quality, choose an option from the pop-
up menu, enter a value between 0 and 12, or drag the slider. The higher the value, the better the 
image quality and the larger the file.  
Note: Photoshop uses the default image interpolation method set in preferences. Choose Bicubic 
Sharper as the default for best results when reducing image size. 

 Border Size Width of the border around the image in pixels.  

 Titles Use (Available for some site styles) Specifies options for displaying captions under each 
image. Select Filename to display the filename, or select Description, Credits, Title, and Copyright 
to display description text drawn from the File Info dialog box.  

 Font and Font Size (Available for some site styles) specify the font and size of the caption. 
 
7. Thumbnails Options for the gallery home page, including the size of the thumbnail images. 

 Size Specifies the thumbnail size. Choose from the pop�up menu or enter a value in pixels for the 
width of each thumbnail.  

 Columns and Rows Specify the number of columns and rows in which to display thumbnails on the 
home page. This option doesn’t apply to galleries that use the Horizontal Frame Style or Vertical 
Frame Style.  
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 Border Size Specifies the width, in pixels, of the border around each thumbnail.  

 Titles (Available for some site styles) Specifies options for displaying captions under each 
thumbnail. Select Filename to display the filename, or select Description, Credits, Title, and 
Copyright to display description text drawn from the File Info dialog box.  

 Font and Font Size (Available for some site styles) specify the font and size of the caption. 
 

8. Custom Colors Options for colors of elements in the gallery. To change the color of an element, click 
its color swatch and then select a new color from the Adobe Color Picker. You can change the 
background color of each page (Background option) and of the banner (Banner option).  

 Security Displays text over each image as a theft deterrent. This is optional. 

 Content Specifies the text to be displayed. Select Custom Text to enter customized text. Select 
Filename, Description, Credits, Title, or Copyright to display text drawn from the File Info dialog 
box.  

 Font, Color, and Position Specify the font, color, and alignment of the caption.  

 Rotation options Place the text on the image at an angle. 
  

9. Click OK to create the gallery. 
 
Photoshop places the following HTML and JPEG files in your destination folder: 

 A home page for your gallery named index.htm. Open this file in any Web browser to preview 
your gallery.  

 JPEG images inside an images subfolder.  

 HTML pages inside a pages subfolder.  

 JPEG thumbnail images inside a thumbnails subfolder. 
 
 

 

References to Learn More on Your 
Own 
 
Web Style Guide 2nd Edition – Graphics 
Section 
http://www.webstyleguide.com/wsg3/11-
graphics/5-web-graphics-formats.html 
 
Gifs .vs Jpgs 
http://www.tips-tricks.com/gif_jpeg.asp 
 
Color Theory 
http://www.worqx.com/color/index.htm 
 
 

Various Image Sources 
 
CVMBS Image Bank 
http://www.cvmbs.colostate.edu/cats/Imagebank
.htm 
most images taken by Charlie Kerlee 
 
CSU Photography Services 
http://photos.colostate.edu/ 
 
Washington State Image Data Base 
The images in this data base are for 
educational, non-commercial use only. 
http://imagedb.vetmed.wsu.edu/ 
Selected images were used on the IVAPM home 
page at http://www.cvmbs.colostate.edu/ivapm/ 

 


