Hands-on Activities for InTech Lab Workshop

Web Design Basics Il — Editing Pages in Dreamweaver
Prepared by Jill Lenz

Presented Spring 2009

During this workshop attendees will explore features in Dreamweaver CS3 that allow management of a
web site with multiple pages. We'll also take a closer look at editing HTML source code, attaching a style
sheet, Web accessibility, and checking your work.

Upon completion of this workshop, users should become familiar with:
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e Editing Text h

e Preserving Links When Renaming/Moving Files

e Dreamweaver’s Clean up Word HTML Command

e Dreamweaver’s Find and Replace command @

e Dreamweaver’s Built-in Spell Checker

¢ Dreamweaver’s Link Checker V

¢ Dreamweaver's Validator WH [ 3 - [I

Web Accessibility Tool

e Free online HTML and Accessibility Validators

Cynthia £

Tested

Exercise 1 - Dreamweaver Site Management Review/Create site

Create a new site that refers to the location of RamCT Histology Orientation files
In Clark C143 the complete address is c:\userdata\hands-on\histo\orientation\
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Exercise 2 — Edit Text

This exercise replicates the task of modifying text in an existing web page.

1.

2.

8.

Open the file orientation.htm by double clicking on the file name in the Files panel on the right.

Looking at Dreamweaver’s Design window, familiarize yourself with Heidi’s portion of the Web page.
You will see there are three parts to her bio that she wants to update.

Open the Word document TA-text-update.doc that has updated text to replace in the HTML file.
This file is located on the desktop in UserData\histo\orientation\. Once you find the file name, double-
click on it to open the file in Word.

Because Heidi's updates are in three separate portions of the Web page, you will need to copy and
paste three times to replace her old text with the new text.

In Word, highlight only the first paragraph with your cursor. Copy the selection.

In Dreamweaver, highlight the first paragraph of Heidi's existing text and paste what you selected in
Word over the existing text.

Repeat steps 5 and 6 two more times to get the 2" and 3" paragraphs from Word and paste over the
existing text in Dreamweaver.

Save the file with the same name. File > Save or CTRL+S.

Exercise 3 — Rename a File and Preserve Links in a Dreamweaver Site

This exercise demonstrates the power of Dreamweaver’s Site Management features.

Work in your Dreamweaver site you just

created for Histo to standardize/rename files
according to the following guidelines:

Update links in the following files?
Jhistopg19_1.htm

\_%
i

Don't Update
e Relatively short names
e All lowercase

e No spaces

1. Torename the file “Mimi peninsula.jpg” to
“Mimi-peninsula.jpg” to avoid spaces in Help |
file names, select that file in your
Dreamweaver Files palette with a single click. Right click on the file name and choose Edit >
Rename. Replace the empty space with a hyphen. Click Enter.
2. You will be asked to “Update links” in a list of files. Yes, you want to update links in the following files
so your links won't be broken. Click “Update”.
3. Save your file. (CTRL + S).
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Exercise 4 — Spell Check
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CSU Website Guideline: Materials should be carefully checked for proper grammar and spelling.

1. Perform a Spell Check in
Dreamweaver on the page you just
edited by pressing SHIFT+F7 or Text >
Check Spelling.

2. The Check Spelling dialog box appears
and when a potential misspelling is
identified, it offers you the options to
“Add to Personal”,

“Ignore”, “Change”, etc. Choose the
appropriate option.

If you start in the middle of the
document, when it gets to the end, it
ask if you want to start at the beginning
of the document. Answer Yes. You will
be notified with the spelling check is
completed.

Check spelling |

Word not found in dictionary:

| veteriary Add to Personal |
Chanage to:

Change |
Ignore All |
;I Change All |

Close | Help |

3. Save the file with the same name. File > Save or CTRL+S.

Exercise 5 — Clean up Word HTML

Remove extraneous “bloat” code generated by Word's “Save as Web Page Filtered” function. This
also decreases the number of lines of HTML code and achieves a smaller file size (KB).

Open a new Word document and type the words “Hello World” without the quotes.

2. File> Save As Web Page and choose the
type “Web Page, Filtered (*.htm, *.html) and

remove any spaces in the file name.

3. Close the Word file.

Open this file in Dreamweaver.

IHEIIo World.him

Web Page, Filtered (*.htm; *.html)

qwWaord Document (*.doc)

¥ML Document (*.xml)

Single File Web Page (*.mht; *.mhtml)
Web Page (*.htm; = himl}
Weh Page, Filtered (*.htm: *.html)
Document Template (*.dot)

In Fal 1l

| 4

Note how many lines of code there is in Dreamweaver's Code window.
(To show line numbers in Code View, use the menu commands View > Code View Options >

Line Numbers.)
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10.
11.

12.

13.
14.
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Note the meta tag <meta name=Generator content="Microsoft..."> that shows it was generated

from a MS Office product.

Note the number of lines of inline styles nested in the <style> tags.
Note all the style attributes that begin with “mso”, short for Microsoft Office.

From the menu, choose Commands > Clean up Word HTML

Select the version of Word that was used to generate the file, “Word 2000 and newer”.

Select all the r
options except Clean Up Word HTML

uncheck Set

background |1 Basic | Detailed
color to [:S
#éiFFFFF' Click Clean up HTML from | Word 2000 and newer A |

Remove all word spedific markup
Clean up C55

Clean up =font> tags

When done, a Fix invalidly nested tags

results log [Jset background color
displays what Apply source formatting

was removed.
Show log on completion

kK
Cancel

Help

How many lines of code do you have now?

Save the file as cleaned_up_word.htm.

Exercise 6 — Check Links in Dreamweaver

1.

Create a new site that refers to the location of the e-insight files.

In Clark C143 the complete address is c:\userdata\hands-on\e-insight\

At the bottom of the Dreamweaver window, locate the Results palette. If you don’t see it, you can

access it under Window > Results.

You may need to expand the palette by clicking on the right pointing arrow.

i ¥ Results search | Reference | Validation | Target Browser Check  Link Checker

Shaw: | w | {links to files not found on local disk)

hrl Files
Chedk Links in Current Document

/ Chedk Links For Entire Current Local Site k
Chedk Links For Selected Files in Site
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Choose the tab labeled “Link Checker”
Under Show: choose Broken Links

Under the Green drop down arrow, choose Check Links for Entire Current Local Site

o gk~ w

Any broken links found will be listed in the Results box. To correct links, you can click on one of the
results and the page will automatically open and take you to the correct line of code to manually
correct.

7. Choose the file /2009/February/index.htm with a double-click and the file will open and the cursor
will be at the location of the broken link. This link can be fixed in the Properties box in two ways

a. Browse for file

Link

irget W
b. Point to file
Link w
arget w

Point to File

Either of these two methods will re-path your links correctly.

Save the file (CTRL + S).

9. Choose the file /2009/February/KromaTID.htm to correct by double clicking on it.

10. Fix the path to the source image link by browsing or pointing to the correct file in your site
(index.htm). Hint: the file is located in the images subfolder. You make have to expand the
subfolder with a click on the plus sign to the left of the folder to see all the image files.

11. File > Save with same name.

12. Run the Link Checker again to confirm you have corrected all the broken links.
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Exercise 7 — Validate your HTML
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Dreamweaver has a built-in validation tools to check for errors in HTML coding. It's a good place to start

then run the same pages through another online validator.

1. Atthe bottom of the Dreamweaver window, locate the Results palette.

2. Choose the tab labeled “Validation”

3. Under the Green drop down arrow, choose Validate Current Document

£ w Results sSearch | Reference  Validation
B, File Line = Desq
Validate Current Document
Validate Entire Current Local Site k
Validate Selected Files in Site
Settings...
i

4. Any coding errors will be listed in the Results box. To correct errors, you can click on one of the

results and the page will automatically open and take you to the correct line of code to manually

correct.

5. In this exercise the “&” is flagged on line 24 in the file 200\January\index.htm. The description in

the Results box explains that “&” should be replaced with equivalent of “&amp;”, the character

string that HTML recognizes for this character.

6. Double-click on the error in the properties box then when your
cursor lands on that line of code, highlight the “&” then type it
in again and a help box will display with a list of character
strings to choose from. You want to choose the second one in
the list, “&amp;”. With a double-click and it will appear in the
code.

7. Save your file. (CTRL +S)

8. Once error-free in Dreamweaver, test with the online validator
from the W3C http://validator.w3.org/
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Exercise 8 — Validate with the W3C Validator

1. Open Internet Explorer

2. To use the W3C Markup Validation Service, type in the URL http://validator.w3.org/

w\;cm Markup Validation Service

Check the markup (HTML, XHTML, ..} of Web documents

Validate by URI Validate by File Upload Validate by Direct Inpurt

3. Choose the tab “Validate by File Upload”.
Note that this Validator can only check one page at a time. The page can be “live” on a server, or
you can validate by “File Upload” which allows you to browse for a local file, or “Validate by Direct
Input” where you copy and paste code from an HTML into the Validator.

4. Click on the “Browse” button and choose the file at this location:
Desktop\UserData\hands-on\e-insight\2009\January\index.htm

5. Click the “Check” button.

6. Your results will be returned in the refreshed page. You want to strive for no errors.

This document was successfully checked as XHTML 1.0 Transitional!

Exercise 9 — Validate for Accessibility

Cynthia Says http://www.cynthiasays.com
This Validator can only check pages that are live on a server.
For an example, test the CSU home page at http://www.colostate.edu/

WAVE http://lwww.wave.webaim.org

Reading these reports takes some knowledge and practice, but are very useful.
Contact Jill Lenz if you need help with these reports on your College-related external Web pages.

Tip: Before propagating new web pages from an existing file, make sure the existing
file validates for correct coding and accessibility!
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Resources
1. University-level

ACNS/CTSS
e Google Apps for CSU https://eid.colostate.edu/gmail/

e Spring 2009 Training Schedule featuring Dreamweaver and Google Apps Sites workshops
https://wsprod.colostate.edu/cwis5/registration/req viewschedule.asp?iDepartment=25

e CTSS contact info
e Phone 491-7276
e Email help@lamar.colostate.edu
e Walk-in assistance 224 Weber Building

e For students, faculty and staff
CSU Dept. of Web Communications

e (CSU Web Site Requirements http://graphicstandards.colostate.edu/index.asp?url=toolbox_web
e (CSU Web Accessibility Standards http://accessibility.colostate.edu/CSUstandards.htm
e CSU Web Access Checklist http://accessibility.colostate.edu/chaccess.rtf

N

. College-level

CVMBS Web Server Space Request https://www.cvmbs.colostate.edu/netserv/resrcreq/
CVMBS Web Server File Transfer Request contact cvmbswebadmin@colostate.edu
RamCT Training and Support: Jamie Bethel, jamie.bethel@colostate.edu

w

. Industry-wide

e HTML Tips
e HTML Goodies — Primers > HTML http://www.htmlgoodies.com/
e W3 Schools http://www.w3schools.com/html/
e Avoid Tag Misuse http://www.w3.0rg/TR/CSS-access
e Web Design
e Quiet Structure http://www.andyrutledge.com/quiet-structure.php
e Getting started on a site design http://www.sitepoint.com/article/wire-frame-your-site
e Information Architecture http://www.digital-web.com/articles/getting_ia_done_part_ii/
e The Net Mechanic Webmaster Tips Newsletter http://www.netmechanic.com/news/
e (CSS
e CSS Box Model http://css.weblogsinc.com/2006/03/29/fun-and-painless-box-model-demo/

e ATRC/CTSS workshop materials on CSS
http://www.colostate.edu/Depts/ATRC/presentations/2005/css_class/structures.htm

e Accessibility
e Cynthia Says http://www.cynthiasays.com/
e WAVE http://wave.webaim.org/
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